RouterOSでUPnPを使用する方法

Blog

皆さん、UPnPって使用しています?

そもそもUPnPとは以下のとおりです。

Universal Plug and Play (UPnP) /
https://ja.wikipedia.org/wiki/Universal_Plug_and_Play

メディアサーバやSkypeなんかを使用するときに利用していると思いますが、これについてもRouterOSは対応しています。が、普通に有効にしただけでは、使用できません。ちょっとした設定が必要です。

Webfigの場合:

上記の画像の通り、Interfaceに対して内側(Internal)と外側(Public)を明示的に指定してやる必要があります。

Internalは以下の通り。

Interfaceを指定して(この場合がBridge1)、Typeを内側だからinternalに設定するだけです。逆にPublicは、Typeをexternalにするだけです。

CLIの場合:

CLIについてはあっさりとしています。慣れているならこちらのほうが簡単です。

/ip upnp
set allow-disable-external-interface=yes enabled=yes
/ip upnp interfaces
add interface=bridge1 type=internal
add interface=gmobb type=external

こちらを設定し、有効になっている場合はIP>Firewall>NATに動的にNATルールが追加されます。

PS4やXboxなんかのオンライン接続を行う場合でもこのあたりの設定が必要だと思いますので、見直してみてください。