PPTPのリモートクライアント接続の設定方法

Blog

Snip20150702_13

とりあえず気軽に、外部から接続する方法としてPPTPとL2TP/IPsec、OpenVPNなどがありますが、今回はPPTPを用いて外部からPCにて接続する方法について書いてみたいと思います。

Manual:Interface/PPTP – MikroTik Wiki http://wiki.mikrotik.com/wiki/Manual:Interface/PPTP#Connecting_Remote_Client

その前にPPTPとはなんぞやという方は以下を参照ください。

ITmedia エンタープライズ:How-To:特別企画:PPTPによるVPNの構築 http://www.itmedia.co.jp/help/howto/linux/vpn/

PPTP を理解する https://technet.microsoft.com/ja-jp/library/gg983536.aspx

PPTPについてはMS CHAPv2を利用した場合の脆弱性が報告されています。使用される際には十分にご注意ください。

認証プロトコル「MS-CHAP v2」の脆弱性に相次ぎ注意喚起 - @IT http://www.atmarkit.co.jp/news/201208/23/mschap.html

基本的にはWikiのとおりですが、今回はWebfigからの設定方法について書いてみます。

前提条件は以下のとおり

  • InternalのIPアドレスは192.168.88.1
  • VPNに払い出すIPアドレスは192.168.88.2〜10

イメージとしては下図のような感じになると思います。

PPTP

1. PPTPに接続してくるクライアントに払い出すIPアドレスを設定する。
IP > Pool > Add New

Snip20150702_5

 

2.  Nameに「vpn」、Addressに払い出すIPアドレス、192.168.88.2-192.168.88.10と設定する。

Snip20150702_6

/ip pool
add name=vpn ranges=192.168.88.2-192.168.88.10

 

3. PPP Profileを作成する。
PPP > Profile > Add New

Snip20150702_1

4.  Local AddressにはInternal Addressである192.168.88.1、Remote Addressには、上記で設定したPool「vpn」を設定する。
またUse Encryptionを「yes」に設定する(※重要)

Snip20150702_2Snip20150702_3

/ppp profile
add local-address=192.168.88.1 name=profile1 remote-address=vpn \
    use-encryption=yes

 

5. PPTP Server設定を実行する。
PPP > Interface > PPTP Server

Snip20150702_8

6. 以下の設定を実施する。

  • Enabledにチェック
  • MRRUは1600
  • Authenticationはchapとmschap2にチェック

Snip20150702_9

/interface pptp-server server
set authentication=chap,mschap2 default-profile=profile1 enabled=yes max-mru=\
    1280 max-mtu=1280 mrru=1600

7. PPTP接続ユーザを作成します。
PPP > secrets

Snip20150702_18

8. 以下の様なパラメータでユーザを作成します。

  • Name: 接続するときのユーザID
  • Password: パスワード
  • Service: pptp
  • Profile: 上記で作成したプロファイル

Snip20150702_19

/ppp secret
add name=vpnuser1 password=パスワード profile=profile1 service=pptp

 

9. Firewall設定を投入している場合は、以下のポートを開放しておくこと。

Snip20150702_12

/ip firewall filter
add chain=input action=accept comment="allow pptp" dst-port=1723 protocol=tcp

あとは、PCやスマートフォンなどに設定を行い、Routerboardに割り振られているグローバルIPアドレスに接続してやることで、PPTP接続ができると思います。

間違いなどありましたら、コメントまたはフォーラムなどでご指摘いただければと思います。